Generating a synthetic joint Gne/Guv gravity gradient inversion 
Feb, 2012
1. Start the ggCalc program
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2. Select Text File as the Data Source and the stations_xyz_dtm.csv as the data file, set the Name line to 1, the first data line to 2 and select the columns to be used. Then click on the Load Data button to check that the data has been read correctly.
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3. Set the Zone Width to 200, the Cell size increase to 3 and the Number of zones to 6 and turn on the components G_UV, G_NE, VKa and VKc and set the Azimuth to 60 (only used for VK components). Finally set the Output file name to Kauring_terrain_response.dat.

[image: image3.png]File Help
Data Source
Data File [stations_xyz_dtm.csv
Line with names [1 First data line. Read Increment
Xcolumn  [x ¥ column [y
Lined  [mE Time
o[LmE
ot
210
3|0
Lo
5|Lot
6|Lot
7|10t
a|Lot
s|Lot
Humber of points

Data Locations’

Survey DTH Fiegional DTM Densiy Gid

Zonewidth  [z00 Zone cellsize increase  [5 " Mumber of Zones F
Average Topo 230 TopobCshift  [g Insert mode [fione. -
Magintensity [ Maginclinaon [ Mg decination
Rema [ Remincinaon [ Remdecination
bensity [z Megsuse a0 Demagiteraons [
Components: [~ TMI [~ Fiip sign of mag response [~ Gz Output Unit Response r
ez Con MGy POW FGHE [V WV Admun [
Output file [Kauring_terrain_response.dat =l
Calcuate Terrain Response | _Exit program





4. Click on the Survey DTM tab and select the LiDAR_10.ers grid file
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5. Click on the Regional DTM tab and select the SRTM.ers grid file
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6. Click on the Calculate Terrain Response button and the program will calculate the terrain response for the selected components and save them to the dat file as well as a csv format file.
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7. To calculate the response of the synthetic bodies, click on the Facet Bodies tab, select the file Body 1.ts and set the output file name to be body 1_calc.dat. Next set the density to 0.2, click on the Save changes button and then click on the Calculate Body Response button
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8. Repeat the process for body 2 using a density of 0.15, body 3 with a density of 0.15, Body 4 with a density of -0.4 and Body 5 with a density of -2.67

9. You can then assemble all of the responses in an Excel spreadsheet, or simply use the files Kauring_terrain_+body_response.csv and Kauring_body_response.csv which have already been generated. (the next version of the program will allow multiple bofies and terrain response to be calculated and saved in one step).
10. Start WinDisp and set the working directory to the Kauring folder, double-click on the Post Data from a Text File, select the body response csv and follow the prompts until you get to the Posting Specifications form. Then select the GPSalt and gravity gradient response columns
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11. Click on the Display Data Range button, set the cell sizes to 25, define the grid output file name and format, turn on the Grid All Data Fields checkbox and click on the Grid Data button. Once the data has been gridded, save the layout for later use.

12. Start a new layout, click on the Edit> Multipanel definitions menu item and select the gradient grids and display the sun illuminated images
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13. Repeat the process using the terrain + body response data file and display the images
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14. It is clear from these images that the terrain response is the dominant component and the body responses are difficult to discern.
15. Click on the Utilities> Create a mag/grav inversion menu item to display the Inversion setup form, select MGinv3D as the Inversion Method, Gne as the Data type and Guv as the second data type
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16. Click on the Observed Data tab, select Grid Data as the Data File Type and select the G_NE body response grid (ie the one without the terrain included) and click on the Set Limits from Data button
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17. Click on the Guv tab and select the G_UV body response grid
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18. Click on the Sensor Grid tab and select the GPSalt grid and specify that the Sensor location is Actual elevation (NB it is very important to remember to do this!)
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19. Click on the Topo Data tab and select the merge.grd dtm grid file
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20. Click on the Mesh tab and change the Z mesh minimum value to -2000 and set the X/Y mesh padding to 1,2,4,8,16,32 and the Z padding to 1,2,4,8
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21. Click on the Create Inversion tab, specify the Output base folder and inversion folder name and add a description of the inversion. Once the files have been created, click on the Start Inversion button.
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22. Once the inversion has run, start up the 3DModeller form, load the mesh and mginv3d.den inversion model, click on the View Model tab, select the Topo Draped Depth as the section to view
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23. Change the Isosurface value to 0.025 and click on the Start 3D Viewer to see the model in 3d
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24. Return to the 3D Modeller form, click on the 3D Files tab and then on the Facet Model tab and drop the ts files onto the form and then click right on the list and select Assign File colours > Blue to Red from the popup menu
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25. Click on the Create New 3D Oblect, specify Synthetic Bodies as the name of the object to create and the inversion model looks like this
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26. It is clear that the inversion is doing a good job of identifying the body 3 in both size, shape and location. It is also identifying the top, thickness and length of body 2, but is not determining the dip. The inversion is also not determining the density of either body (it should be 0.15 for body 2 and 0.3 for body 3). Adding a second isosurface with a density of -0.025 shows that the inversion is doing a good job of locating body 4 in size and position, but not in shape, depth to top or density. Play around with the isosurface level to see how well bodies 1 and 5 can be displayed.
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27. Return to the Inversion creation form, change the Inversion Mode to Apparent den/susc, change the X/Y cell sizes to 50 and then create the inversion in a new folder and run it. The AppDen inversion needs to have a new mtx file generated, but it is much faster than the full 3D inversion so smaller cell sizes can be used. When the inversion is finished, load the mesh and mginv3d.den file as before and display the topo draped image 
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28. If you look at an EW section, you can see that the model consists of vertical prisms with a constant density.
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29. Return to the Inversion setup form and read the original 3D inversion parameter file to return the mesh and inversion mode settings. We now want to run the full 3D inversion using the data containing both the terrain and body responses. In this case, the observed data needs to be regenerated using the new grids, but the mtx files can be reused. This can be most easily achieved by setting up the new inversion and then copying the mtx files into the new inversion folder. But the Inversion Variation process can also be used as follows. Click on the Observed data tab and select the terrain and body G_NE grid.

[image: image25.png]5 3D inversion setup: Joint_Guv_Gr
File Change Working Directory

inp. =lofx]

Paamelers | (ObservedData | TopoDas | = [ Ceseimeson )
Dsta Files Target Data Eror
e e
- Sensor Location- ‘Regional field:
Defined Valucis [ Actual Sensor eievation <] Offset [10 M Height [i ’Vhev.lz oo

ObserveaData[Kauring_ferran_shody_rosponse_G_IE responsegrd L

Gne data grid Guv data gid Sensor Giid





30. Click on the Guv tab and select the terrain anb body Guv response grid
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31. Click on the Create Inversion tab and select the Joint_Guv_Gne inversion folder created earlier. Specify a folder name of Joint_Guv_Gne_terrain and click on the Create Inversion button, but do not click on the Start Inversion button yet.
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32. Return to the Paramaters tab, turn on the Generate Inversion Variation checkbox and select Terrain correlation as the Background Removal method. Note that all of the parameters with green labels can be modified without requiring the calculation of a new mtx file.
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33. Return to the Create Inversion tab and click on the Generate Variation button to rewrite the inversion input files to use the existing mtx files
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34. If you look at the original mginv3d.inp file, it looks like this:
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While the variation version in the sub-folder looks like this:
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35. For a usual variation, the new inversion will resuse the existing grav.obs and mtx files. But for this case, we want to use the newly generated grav.obs file, so edit it and change the line that reads ..\grav.obs to read simply grav.obs
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36. Also, edit the run_mginv3d.bat file and change the reference to the grav.obs file so that it points to the one in the sub-directory ie change the file from this:
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To this
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37. With the files edited in this manner, click on the Start Inversion button and you should see the inversion start up look like this:
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The important thing to note here is that the background density value calculated by the program is 2.71 g/cc, so it has overestimated the regional density. 

38. Once the inversion has run, load the model as before and it now looks like this
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39. To remove the edge effects, click on the 3D Files tab and select merge.grd as the Topo grid and the G_NE response as the Draped Image. Then return to the View Model Tab and click on the Edit> Mask model using Topo> Clip Model laterally using Draped grid so the model looks much better

[image: image37.png]£3 3D Modeller: DAWUG2012\Kauring\Joint_Guv_Gne\Joint_Guv_Gne_terrain\
File Creste 3DGridding Edit CreateNew3D Object Display Help

Mesh and Model

Display Options

I Display section in 3DViewer Save Sections.

Secton to view <] oepmorset  [z0 xewums | e 2
Isosurface value [o007 Bue [2omise Red [27ommes Yoiplmis i i <
Smooth model [~ Grid celspit [1 Colour styie ] ivertColour [ zeipLimits i i 2

Oblique Section

sartviower |

5043698 6470031





40. To remove some of the noise effects we could run an inversion variation using a larger trade-off parameter. It is also possible to directly smooth the model to reduce the amount of chatter by clicking on the Edit> Smooth Model menu item and specifying a central weight of 10. The value is the weight assigned to the centre point of the 3x3x3 smoothing convolution filter, so a larger value implies less smoothing. After smoothing, the model looks like this
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41. If we now add the 0.025 g/cc isosurface from this model to the existing 3D model, you can see that the result is similar to the previous 3D inversion, but the densities attained are much lower and so also is the depth extent of Body 2.
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42. If we repeat this process for the Apparent Density style inversion the background density is calculated as 2.687 and the model is displayed below. Clearly the residual terrain effects are enough to mask the presence of most bodies in the inversion model. Body 2 is still quite evident, but body 1 is very diffuse and body 3 is very marginal. The residual terrain effects are due to both the different in density as well as the difference between the 50m cells in the inversion model relative to the 10m cells used in the terrain calculation.
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